const regex = /ORDER BY.*?(?=\s*LIMIT|\)|$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ORDER BY.*?(?=\\s*LIMIT|\\)|$)', 'gmi')
const str = `SELECT * FROM table ORDER BY name
SELECT a.* FROM (SELECT * FROM table ORDER BY name, created_at) AS a ORDER BY a.name
SELECT t0.* FROM table t0 WHERE t0.created_at IS NOT NULL ORDER BY t0.name, t0.created_at, t0.status LIMIT 10 OFFSET 10`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);