package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^_]+_`)
var str = `name_001.png
na-m-e_001_tr.png`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}