use strict;
my $str = 'name_001.png
na-m-e_001_tr.png';
my $regex = qr/^[^_]+_/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";