#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\{\{(\d+)(,(\d+))?\}\}"
Local $sString = "This is my first example string. {{1}} This is what it looks like." & @CRLF & _
"This is my second example string. {{1,2}}. This is what it looks like." & @CRLF & _
"This is my third example string. {{1,3}} and {{2}}. This is what it looks like."
Local $sSubst = "<input name="var$1" value="$3" />"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)