use strict;
my $str = 'This is my first example string. {{1}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{1,3}} and {{2}}. This is what it looks like.';
my $regex = qr/\{\{(\d+)(,(\d+))?\}\}/mip;
my $subst = '<input name="var$1" value="$3" />';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";