// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\{\{(\d+)(,(\d+))?\}\}").unwrap();
let string = "This is my first example string. {{1}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{1,3}} and {{2}}. This is what it looks like.";
let substitution = "<input name=\"var$1\" value=\"$3\" />";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}