package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`msgid\s*("(?:[^\\"]*\\.)*[^\\"]*")`)
var str = `"Testing if \"quotes\" are working." from msgid "Testing if \"quotes\" are working."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}