using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"PASSWORD\((?i)secret_?(?i)key\:[""|'|`]?[""|'|`]?\)";
string input = @"# Match this, double quotes included
PASSWORD(secret_key:"")
# Match this, single quotes included
PASSWORD(secret_key:'')
# Match this, back quote included
PASSWORD(SECRETKEY:``)
# Match this, no quotes included
PASSWORD(SECRETKEY:)
# No match, arrow brakets not included in pattern
PASSWORD(secretkey:<>)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}