package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PASSWORD\((?i)secret_?(?i)key\:["|'|`]?["|'|`]?\)`)
var str = `# Match this, double quotes included
PASSWORD(secret_key:"")
# Match this, single quotes included
PASSWORD(secret_key:'')
# Match this, back quote included
PASSWORD(SECRETKEY:\`\`)
# Match this, no quotes included
PASSWORD(SECRETKEY:)
# No match, arrow brakets not included in pattern
PASSWORD(secretkey:<>)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}