use strict;
my $str = '# Match this, double quotes included
PASSWORD(secret_key:"")
# Match this, single quotes included
PASSWORD(secret_key:\'\')
# Match this, back quote included
PASSWORD(SECRETKEY:``)
# Match this, no quotes included
PASSWORD(SECRETKEY:)
# No match, arrow brakets not included in pattern
PASSWORD(secretkey:<>)';
my $regex = qr/PASSWORD\((?i)secret_?(?i)key\:["|'|`]?["|'|`]?\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}