package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-\$\d{1,3}(?:,\d{3})*$`)
var str = `-$1,200
-$750
-$10,000,000,000
-$100,000,
-$1,2
-$,000
-$1200
$1,200
$750`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}