$re = '/\[IF\s#(!)?([^\#]+)\#\](.*)(?:\[ELSE](.*))?\[\/IF]/s';
$str = '#QST_COUPLE="Me contacter vous pour un problème de couple ?"#
[IF #COUPLE#]
[IF #!PRENOM_PARTENAIRE#]
Quel est le prénom de votre partenaire ?
#GET_PRENOM_PARTENAIRE#
Bien, nous allons pouvoir commencer votre tirage tarot maintenant !
[ELSE]
oooo
[/IF]
[/IF]
[IF #!CATEGORIE#]
[/IF]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);