import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w\\s(а|но)[^w]";
final String string = "здесь но ты\n"
+ "здесь, но ты\n\n"
+ "здесь но, как говорилось\n"
+ "здесь, но, как говорилось\n\n"
+ "но теперь\n"
+ ". но теперь\n\n"
+ "а я\n"
+ " а я\n"
+ ". а я\n"
+ "фыва а, аыв";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}