re = /\w\s(а|но)[^w]/
str = 'здесь но ты
здесь, но ты
здесь но, как говорилось
здесь, но, как говорилось
но теперь
. но теперь
а я
а я
. а я
фыва а, аыв'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end