using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<metric>.*)(?<fields>:{.*})? (?<value>.*)";
string input = @"jvm_buffer_memory_used_bytes{id=""direct"",} 81920.0
jvm_buffer_memory_used_bytes{id=""mapped"",} 0.0
jvm_threads_live 23.0
tomcat_global_received_bytes_total{name="" http - nio -8080"",} 0.0
tomcat_global_received_bytes_total{name=""http-nio-8080"",} 0.0
jvm_gc_pause_seconds_count{action=""end of minor GC"",cause=""Allocation Failure"",} 7.0
jvm_gc_pause_seconds_sum{action=""end of minor GC"",cause=""Allocation Failure"",} 0.232
jvm_gc_pause_seconds_count{action=""end of minor GC"",cause=""Metadata GC Threshold"",} 1.0
jvm_gc_pause_seconds_sum{action=""end of minor GC"",cause=""Metadata GC Threshold"",} 0.01
jvm_gc_pause_seconds_count{action=""end of major GC"",cause=""Metadata GC Threshold"",} 1.0
jvm_gc_pause_seconds_sum{action=""end of major GC"",cause=""Metadata GC Threshold"",} 0.302
jvm_gc_pause_seconds_max{action=""end of minor GC"",cause=""Allocation Failure"",} 0.0
jvm_gc_pause_seconds_max{action=""end of minor GC"",cause=""Metadata GC Threshold"",} 0.0
jvm_gc_pause_seconds_max{action=""end of major GC"",cause=""Metadata GC Threshold"",} 0.0
jvm_gc_live_data_size_bytes 5.0657472E7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}