$re = '/(?:,\s*(?P<arg>\w+))/';
$str = '"connected to %s:%d", ip, port';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);