# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*|\"(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])*\")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])$"
test_str = ("abcd1090@ihavenoidea.what.going.wrong.here\n"
"abcd1090ihavenoidea.what.going.wrong.here@\n"
"abcd1090@ihavenoidea.what.going.wrong.here.\n"
"@abcd1090ihavenoidea.what.going.wrong.here\n"
".abcd1090ihavenoidea.what.going.wrong.here\n"
"abcd1090ihavenoidea.what.@going.wrong.here\n"
"abcd1090ihavenoidea.what@.going.wrong.here\n"
"abcd1090ihavenoidea.what.going.wrong.here\n"
"abcd1090@ihavenoidea.what.going.wrong..here\n"
"abcd1090@ihavenoidea.what.going.wrong...here\n"
"abcd1090@ihavenoidea.what.going.wrong@@here\n"
"nowordwithnospace\n"
"john.smith@email.com\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.