use strict;
my $str = '<p>This is a "wonderful long text". At least it should be. Here we have a <a href="http://wwww.site-to-nowhere.com" target="_blank">link</a>.</p>';
my $regex = qr/<a.*?<\/a>(*SKIP)(*F)|"([^"]*)"/p;
my $subst = '»\\1«';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";