package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:1?\d(?:\.\d\d?)?|20)$`)
var str = `19.33
0.2
0.91
0
2.4
15.88
20
0
0.5
0.91
1
20.1
21
22
23
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}