const regex = /^(?:1?\d(?:\.\d\d?)?|20)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:1?\\d(?:\\.\\d\\d?)?|20)$', 'mg')
const str = `19.33
0.2
0.91
0
2.4
15.88
20
0
0.5
0.91
1
20.1
21
22
23
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}