import re
regex = re.compile(r"^(?:1?\d(?:\.\d\d?)?|20)$", flags=re.MULTILINE)
test_str = ("19.33\n"
"0.2\n"
"0.91\n"
"0\n"
"2.4\n"
"15.88\n"
"20\n"
"0\n"
"0.5\n"
"0.91\n"
"1\n"
"20.1\n"
"21\n"
"22\n"
"23\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")