// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[color=(.*?)\](.*?)\[\/color\]").unwrap();
let string = "[color=red;font-size:100pt;]DEFACED[/color]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}