// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[color=(#[0-9A-F]{3,6})\](.*?)\[\/color\]").unwrap();
let string = "[color=red;font-size:100pt;]DEFACED[/color]
[color=#FF0000]DEFACED?[/color]";
let substitution = "<span style=\"font-color:$1>$2</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}