import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "[*\\s]*@(?P<name>[\\w\\\\]+)\\s*\\(?(?P<value>(?:[^@]*[^*\\s/)]))?(?:\\s|$|\\))";
        final String string = "/**\n"
	 + " * Headline\n"
	 + " * \n"
	 + " * Desciption\n"
	 + " * On multiple\n"
	 + " * Lines\n"
	 + " *\n"
	 + " * @test ett\n"
	 + " * @igen tvÄ\n"
	 + " */";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS | Pattern.MULTILINE | Pattern.UNICODE_CASE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}