$re = '/(?!0000)[0-9A-F]{4}/';
$str = '0000
0001
AF10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);