package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+[-* ](\w+)[-* ]\d{4}-\d{2}-\d{2}`)
var str = `3*Canada-2022-06-04
144 Brazil*1998-11-26
18_USA-2009-05-16`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}