const regex = /'?(\w+(?:\s+\w+)*)'?\s+<?(\S+@[\w.-]+\.[a-zA-Z]{2,4}\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'?(\\w+(?:\\s+\\w+)*)\'?\\s+<?(\\S+@[\\w.-]+\\.[a-zA-Z]{2,4}\\b)', 'g')
const str = `Name Surname email@domain.com
'Name Surname' <email@domain.com>
'Name Surname' email@domain.com
Name Surname <email@domain.com>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}