package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'?(\w+(?:\s+\w+)*)?'?\s*<?(\S+@[\w.-]+\.[a-zA-Z]{2,4}\b)`)
var str = `Name Surname email@domain.com
'Name Surname' <email@domain.com>
'Name Surname' email@domain.com
Name Surname <email@domain.com>
email@domain.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}