$re = '/^([0-9]*)(\\\\*)$/';
$str = '10';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);