$re = '/\d+\s*X\s*\K\d+/';
$str = '6 X 8
6X8
600X800';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);