const regex = /runScript(?<match>\((?:\g<match>|[^()]++)*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('runScript(?<match>\\((?:\\g<match>|[^()]++)*\\))', 'g')
const str = `runScript("test")
runScript( "test2" )
runScript(ros.find("p")+ "script/test3")
if( true) then { runScript(ros.find("p")+ "script/test4")}
if( runScript(ros.find("p")+ "script/test5") ) then{
print.ln("happy")
}
runScript(
ros.find("p")+ "script/test6"
)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}