// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"runScript(?<match>\((?:\g<match>|[^()]++)*\))").unwrap();
let string = "runScript(\"test\")
runScript( \"test2\" )
runScript(ros.find(\"p\")+ \"script/test3\")
if( true) then { runScript(ros.find(\"p\")+ \"script/test4\")}
if( runScript(ros.find(\"p\")+ \"script/test5\") ) then{
print.ln(\"happy\")
}
runScript(
ros.find(\"p\")+ \"script/test6\"
)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}