$re = '/^(.*?)\s*(?=[*\[]|[^*\[]$)/m';
$str = 'This should be captured up to here[ but no further]
This should be captured up to this asterisk* but not after it*
This entire line should be captured.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);