const regex = /\bf\b((?!')(?!\")(?!\())/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bf\\b((?!\')(?!\\")(?!\\())', 'gmi')
const str = `f
f(aaa) + f
f + 2
a+ fcc + 9 -f
if({f_b}=0,' -B',' -F -B')
B + 5 + f(aaa, b)
b(aaa) + b
"b"
'f'
a=-f(aaa)`;
const subst = `FOUND`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);