import Foundation
let pattern = #"\bf\b((?!')(?!\")(?!\())"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
f
f(aaa) + f
f + 2
a+ fcc + 9 -f
if({f_b}=0,' -B',' -F -B')
B + 5 + f(aaa, b)
b(aaa) + b
"b"
'f'
a=-f(aaa)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"FOUND"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)