#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<order>(\d+))\n(?<start>([\d:,]+))[\s-{2}\>]+(?<end>([\d:,]+))\n(?<text>(.+|\n))"
Local $sString = "1" & @CRLF & _
"00:01:35,418 --> 00:01:43,418" & @CRLF & _
"In 2015 an American archeological company" & @CRLF & _
"bought a military manuscript from the Han Dynasty" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:01:45,293 --> 00:01:49,501" & @CRLF & _
"It said" & @CRLF & _
"Roman soldiers went to China 2,000 years ago" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:01:49,918 --> 00:01:53,084" & @CRLF & _
"and the ancient city of Regum was bulit" & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"00:01:53,918 --> 00:01:57,084" & @CRLF & _
"The archeological community believed" & @CRLF & _
"it was a fake"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")