using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<order>(\d+))\n(?<start>([\d:,]+))[\s-{2}\>]+(?<end>([\d:,]+))\n(?<text>(.+|\n))";
string input = @"1
00:01:35,418 --> 00:01:43,418
In 2015 an American archeological company
bought a military manuscript from the Han Dynasty
2
00:01:45,293 --> 00:01:49,501
It said
Roman soldiers went to China 2,000 years ago
3
00:01:49,918 --> 00:01:53,084
and the ancient city of Regum was bulit
4
00:01:53,918 --> 00:01:57,084
The archeological community believed
it was a fake";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}