re = /[\w .,-]+:[\w .,-]*[^\W_][\w .,-]*;/m
str = 'ONE:;TWO:,,d,-;THREE:fsdfsd;FOUR:43879293847;FIVE:dsa. dsa, 56;SIX: ;SEVEN:,,,;EIGHT:--;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end