import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " *\\\"[^\\\"]+\\\" *|[^\\r\\n\\\"]+";
final String string = "\"Content1 \n"
+ " block\" \n"
+ " Contentn2 \n"
+ " New conenet \" \n"
+ " Conetent 3\"\n\n"
+ "\"Content1 \\r\\n block\" \\r\\n Contentn2 \\r\\n New conenet \" \\r\\n Conetent 3\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}