// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)").unwrap();
let string = "\\keys_define:nn { test } {
c .tl_set:N = \\l_test_some_tl,
d .tl_set:N = \\l__test_test_variable_tl
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}