using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|""([^""]*)""|(\S+))";
string input = @"tennissrchkey1 tennissrchkey2 ""tennis srch key 3"" ""tennis srch key 4"" ""tennis srch key 5""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}