re = /(?|"([^"]*)"|(\S+))/m
str = 'tennissrchkey1 tennissrchkey2 "tennis srch key 3" "tennis srch key 4" "tennis srch key 5"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end