const regex = /^\s*\d{1,2}(\s*[,\s]\s*\d{1,2})*\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\d{1,2}(\\s*[,\\s]\\s*\\d{1,2})*\\s*$', 'gm')
const str = `11111111
1
1 2 3 3 4 5 7 17
1, 2,3,11,74
1,11,14, 15
1,11,14,, 15
111, 101
1 2 3 a
1, 25, 5.0
1,, 7, 80
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}