// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*\d{1,2}(\s*[,\s]\s*\d{1,2})*\s*$").unwrap();
let string = "11111111
1
1 2 3 3 4 5 7 17
1, 2,3,11,74
1,11,14, 15
1,11,14,, 15
111, 101
1 2 3 a
1, 25, 5.0
1,, 7, 80
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}