#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s(?!\s)|[()\[\]]+\s+[()\[\]]+(?=\.)|(\s)"
Local $sString = "H o w T o C r a f t () [.zip" & @CRLF & _
"V i d e o G a m e () [.zip"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)