$re = '/("+)(.*[\\\\"]?.*?)+?\1/';
$str = '"""hello"""
"hello\\"world"
"""hello world"""""
""hello\\""world \\"" dada""
"hello world \\\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);