$re = '/^[AQ]:.*(?:\n+(?![AQ]:).+)*/m';
$str = 'Q: This is a question.
Q: This is a 2nd question
on two lines.
A: This is an answer.
A: This is a 2nd answer
on two lines.
Q: Here\'s another question.
A: And another answer.
Testing.
123.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);