#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(f+r+u+i+t+s+|v+e+g+e+t+a+b+l+e+s+|f+i+b+e+r+)"
Local $sString = "You should eat fruuits, vegetaaables, and fiiibeeer every day" & @CRLF & _
"You should eat fffffruuits, vegettttaaables, and fiber every day" & @CRLF & _
"You should eat fruuiiiits, vvvvvegeettaaables, and fibeeer every day"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")