package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(f+r+u+i+t+s+|v+e+g+e+t+a+b+l+e+s+|f+i+b+e+r+)`)
var str = `You should eat fruuits, vegetaaables, and fiiibeeer every day
You should eat fffffruuits, vegettttaaables, and fiber every day
You should eat fruuiiiits, vvvvvegeettaaables, and fibeeer every day`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}