// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(f+r+u+i+t+s+|v+e+g+e+t+a+b+l+e+s+|f+i+b+e+r+)").unwrap();
let string = "You should eat fruuits, vegetaaables, and fiiibeeer every day
You should eat fffffruuits, vegettttaaables, and fiber every day
You should eat fruuiiiits, vvvvvegeettaaables, and fibeeer every day";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}